“Accessing” LTPP Data
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Introduction

Data from the LTPP Program has been distributed to the public for more than 10 years.
In the early 1990’s, data was provided in ASCII or Excel files, and much work was
required to get the data into a usable format. Microsoft Access became a popular tool for
analyzing the LTPP data by the late 1990’s. By 2001, most data requestors wanted data
in Access format. The LTPP Standard Data Release (SDR) is now distributed in Access
2000° databases.

The LTPP tables are grouped into modules based on their data content (see module listing
sheet in Appendix A). For example, all of the tables containing materials testing results
are in the Material_Test module. Each module is stored in a separate database file.

Extracting Compressed Files

The database files in the SDR CD’s have been compressed to save space. These can be
unzipped by double-clicking on each module file. The screen in Figure 1 will be
displayed when the user double-clicks on the Adminstrative.zip file.
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Figure 1. Winzip Window showing contents of Administrative.zip

At this point, the database contents can be viewed by double-clicking on the database file
(Administrative.mdb), or the database file can be extracted and saved to the hard-drive.
Saving these files to the hard-drive is recommended because once the database file is
saved to rewritable media, the database can be customized to the user’s needs.

Saving LTPP Database Files

To extract LTPP data from the SDR CD’s to a hard-drive, follow the steps listed below.
Uncompressed, all data modules from CD 1 of the SDR fill approximately 6.3 GB of
data. Individual data modules can be extracted and saved if less space is available or
some modules are not needed.

1. Check for necessary amount of disk space.
2. Create a folder in which to save the database files.
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3. Single-click on the database file (*.mdb) in the Winzip window and click on the
“Extract” button. The screen in Figure 2 will be displayed.
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Figure 2. Screen to select extraction location

4. Click on the down arrow in the “Extract to:” box to choose the folder into which the
database file will be saved. In this example, a folder titled “LTPP” was specified.
5. Click the “Extract” button to save the file to the specified location.

Opening an Access Database

There are several ways to open a database file in Access 2000. The easiest is to double-
click on the file (*.mdb) in Windows Explorer. The database will open in Access,
displaying a list of tables as shown in Figure 4.

Alternately, the user can begin by starting Access 2000® from the Start/Programs Menu
in Explorer and following these steps:

1. The initial Microsoft Access screen will prompt the user to create a new database file
or open an existing file. Click “OK” to open an existing file.

2. The Open file window is displayed. Click the “Look In:” pull down menu and select
the folder (directory) in which the database files are stored. All files matching the
“Files of type” filter at the bottom of the window are listed (see Figure 3).

3. Select a database and click on the “Open” button. A list of the tables in the selected
database will appear (see Figure 4).

Otherwise, if Access 2000 is already running, the File>Open menu item or Open button
=

can be used to open a new file.
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Figure 3. Open File Window with Database Files Listed
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Figure 4. Tables in the Administrative Module

The tables contained in the Administrative module are shown in Figure 4. This screen

provides options to open a table to view the data and to view/change the design of a table.
Clicking on the “Open” button after selecting the EXPERIMENT_SECTION table shows
the data in the EXPERIMENT _SECTION table (see Figure 5).
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Figure 5. Contents of EXPERIMENT_SECTION table

Database tables contain data organized in rows (records) and columns (fields or
elements). All elements in a single row of data are related and are kept together. Each
element is identified by the column header or field name. As the user tabs through the
elements, a description for each element is displayed at the bottom of the screen. In
Figure 5, there is a description for the STAE_CODE element at the bottom of the screen.
The current record number and the total number of records contained in the table are in
the lower left corner of the table screen.

The EXPERIMENT _SECTION Table and Key Fields

The EXPERIMENT _SECTION table (Figure 5) contains at least one row or record for
each highway section in the LTPP Program. This table is considered the master table for
the entire database. Each record has data related to the section identified by the
STATE_CODE and SHRP_ID fields (columns).

Most tables in the LTPP database have the STATE_CODE and SHRP_ID fields. These
two fields are always “key” fields. In other words, these two fields are required, along
with other “key” fields, to identify a single row or record in a table. This group of key
fields is also called the “primary key.”
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Access defines the primary key as the fields that hold data that
uniquely identifies each record in a table. Access automatically
creates an index on the primary key of a table and uses it to find
Primary records and to create joins between tables. The primary key index
Key requires an entry in each primary key field and allows no
duplicates. The order of the fields in a multiple field primary key
determines the default sort order for the table.

The key fields in a table can be identified in the design view of the table. The design

view is displayed when a table is selected or open and the Design View Button —— J is
clicked. The design view of the EXPERIMENT_SECTION table is shown in Figure 6.

The design view shows all of the fields that make up the table, the data type of each field,
and a description of each field. Each field that is part of the key has the key symbol

.ﬁ. in the far left column.

The contents of the table are displayed by clicking on the Datasheet button ; E
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Figure 6. Design View of EXPERIMENT_SECTION Table
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Manipulating Data with Access 2000®
Whenever a table is opened, the following toolbar is displayed:

M- BERY 2R o

@ 4 Ell%v}ﬂnrfm:@,

2.

Sorting Data

Several of the buttons in the toolbar can be used to manipulate data in a table. For
example, to sort records, select one or more fields in the table (click on the field name(s)

A
at the top of each column) and then click on the Sort Ascending 31‘ or Sort Descending

Z

ﬂl' button. Each column used for sorting will be highlighted, as shown in Figure 7. All
of the records will be sorted based first on the values in the leftmost selected column and
then on selected columns to the right. When sorting by multiple columns, the columns
must be adjacent to each other. Click and drag column headers to reorder columns. In
the example below, the EXPERIMENT_SECTION table will be sorted by the
STATE_CODE column and then the SHRP_ID column. Sorting can take some time,
depending on the size of the table.
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Figure 7. Sorting EXPERIMENT_SECTION by STATE_CODE and SHRP_ID fields
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Filtering Data

Rows of data can be filtered according to specific data values. Filtering will allow the
user to view specific rows of data while hiding the remainder of the data. The table can
be filtered either by selection or by form. To filter by selection, find a data value of
interest in a column (such as STATE_CODE = 1) and highlight the data value with the

cursor. Go to the toolbar and click ,,-'i filter by selection. The table will then display
only those rows that contain that data value in that column. In this case, only the rows
with a “1” in the STATE_CODE field will be displayed. The user will notice that the
number of records at the bottom of the screen is modified to show only the number of
rows displayed with the filter applied. To remove the filter and have all records

displayed again, click on the filter on/off button !? :

To filter by form, click on the Filter by Form button to display a form that accepts a
value for each field in the table. One or more fields can have values specified on this
form. Wildcards can be used on the form to get related or similar values in a particular
field. For example, if “like ‘01**” is entered in the SHRP_ID field, all records with the
first two digits of the SHRP_ID equal to “01” will be displayed.

Access will often correct syntax errors when criteria are
specified. For example, in the filter form, if the user types “01*”
for a value, Access interprets it as “like ‘01*"”

Syntax
Errors

Creating A Customized LTPP Database
A database of selected LTPP tables can be useful because only tables of interest can be
pulled together, saved together, and manipulated together, without using unnecessary

hard-drive space. To create a new database in Access, select File > Open or click on the
Q I button. Select “Database” and click “OK”. The File New Database Screen will

appear to allow the user to create a new database file (Figure 8).

ETEY
Save in [ er =] - | & = 5 - Tools -

[:I Addresses

1 amrms

1 Data Client Requesks
L_Q Diaka Request DE

|1 Documents

1 DP Information

|1 LTPP Software

|1 Material Client Requests
|1 Procedures

1 Reference Docs

File pame: IMyLTPPDatabaselmdb vI E reate I
Save as bype: IMichsoFt Access Databases (Y. mdb) vI Cancel I

Figure 8. Screen to specify filename for new database
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Click on the “Save In:” pull-down box to select the directory to which you want to save
the new database file. Type a descriptive name for the new file in the “File Name:” pull
down box. Figure 8 shows an example of creating the database “MyLTPPDatabase” in
the “LTPP” directory. Click the “Create” button, and the Database Screen will be
displayed (Figure 9).

-ioix
Jﬁile Edit Wiew Insert Took Window Help |
ID@EHERY | i2Ry o |%- 8- %|E S8 0.

gE MyLTPPDatabase : Database EIE 5[

open joff Design :

Create table by using wizard
Create table by entering data

Groups

Ready [ o o

Figure 9. Database Screen

Next, select File > Get External Data > Import from the main menu. Click on the “Look

in:” drop down box and select the directory to which you have saved your LTPP database

files. At this point, you should see a list of database files similar to the one in Figure 10.

wport . 1 B
i | | @ |@ ¥ 5 - Tooks -

L7 fuito_weather_Station.mdb

1) Backealculation. mdb

!Ei Climate.mdb

Ezi Dwnamic_Load_Response.mdb
[F]|Fw'D_Diata without_Drop_Data.mdb
EE‘ Ground_Penetrating_Radar.mdb
Ezi Inventory.mdb

Ezi Maint_Rehab.mdb

Ezi Material_Test.rmdb

iMonitoring. mdb

Ezi Seasonal_Monitoring.mdb

!Ei Specific_Paverment_Studies.mdb
!Ei Traffic.mdb

File name: I ;I [ Import I
Files of L‘ﬂ:u?i IMicr-:-s-:-Ft Access (¥ mdbg®, adp;®, mdw; ¥, mda; ¥, mde; *.a:il Cancel |

Figure 10. Import Window with LTPP Database Files Listed
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You can select an entire database to import by clicking on a database file in the list and
clicking the “Import” button. Or, you can import individual tables by double-clicking on
a database file to display a list of tables included in that database. Double-clicking on the
Monitoring.mdb file will display the tables shown in Figure 11. Select one or more
tables (or queries or forms, etc.) from the list and click ok. This will import the selected
objects into the MyLTPPDatabase.mdb file. Repeat these steps for all desired tables.

Rk

Tables |Queries | Farms | Feparts i Pages | Macros I Madules I

COCES = (8].4
CODETYPES

EXPERIMENT _SECTION Cancel
LTPROD

LTRPPTD

MON_CATEGORY
MON_DIS_AC_REY

MON_DIS_CRCP_REY Select Al
MON_DIS_JPCC_FALLT

MON_DIS_JPCC_FALLT SECT Deselact Al
MON_DIS_IPCC_REY

MON_DIS_PADIAS AC x| Cptions =

Figure 11. Tables in the Monitoring Database

Adding Tables to an Existing Database

The procedure for adding tables to an existing database is identical to the procedure for

creating your own database, described above, except for the first step. Before importing
any tables, open an existing database with any of the methods described in the “Opening
an Access Database” section. Then import additional tables as described in “Creating a
Customized LTPP Database.”

For example, a few sets of SDR 18.0 are missing the TRF_BASIC_INFO table* from the
Traffic data module. To import this table into the Traffic.mdb database file stored in the
C:\LTPP directory on your hard-drive, follow the steps listed below.

1. Through Explorer, find the directory in which the Traffic.mdb file is stored on your
hard-drive (e.g., C:\LTPP).

2. Double-click on the Traffic.mdb file to open it in Access. The tables in Figure 12
will be displayed.

3. Select File > Get External Data > Import from the main menu. Click on the “Look
in:” drop down box and select the directory to which you have saved the
TRF_BASIC_INFO.mdb file.

! Contact LTPP Customer Support at LTPPInfo@fhwa.dot.gov to request the TRF_BASIC_INFO table if
you need it. The table will be delivered by e-mail in an Access database file, TRF_BASIC_INFO.mdb.
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Figure 12. Tables in Traffic.mdb file

4. Double-click on the TRF_BASIC_INFO.mdb file. Select TRF_BASIC_INFO from
the table list and click OK (see Figure 13).

Import Objects B _'?lﬁl
Tables |_Queries-| Forms I Re_pn:nrts] Pages I Macrn:us] Maodules |
2k
Canicel
Select Al
Deselect Al
Qptions =

Figure 13. Import TRF_BASIC_INFO table

TRF_BASIC_INFO is imported into the Traffic.mdb file and is listed with the other
tables as shown in Figure 14.
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Figure 14. TRF_BASIC_INFO in the TRAFFIC database

Database Objects in Access

An “object” in Access is any of the things listed under the Object heading in Figure 14,
above. Tables are objects; reports are objects; queries and forms are objects. Clicking on
each object type in the object list will display a list of that object type contained in the
current database file. The LTPP SDR 18.0 only contains table objects. However, users of
the LTPP data are encouraged to create their own queries and reports to support analysis
of the data.

Simple Queries

You use queries to view, change, and analyze data in different ways.
You can also use them as the source of records for forms, reports, and

Query data access pages. The most common type of query is a select query.
A select query retrieves data from one or more tables by using criteria
you specify and then displays it in the order you want.

A query is a question asked of a database. It can combine data from one or more tables
or even other queries. This section will discuss single-object queries.

Create a Single-Object Query

The simplest and most common type of query is similar in result to the filters discussed in
the Filtering Data section. A SELECT query creates a subset of data that matches certain
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criteria specified by the user. For example, you could select all of the data in the
EXPERIMENT_SECTION table for highway sections located in Alabama
(STATE_CODE =1). The results of this query would be identical to the records
displayed by the filter we used in our earlier example.

Listed below are the steps required to create the subset of data records in
EXPERIMENT_SECTION for Alabama highway sections.

1. Using the Traffic.mdb data file, click on “Queries” from the Object list in the
database screen (Figure 14). Any queries you have created and saved will be listed.

2. The first two items in the list are query-building options. Double-click the “Create
Query in Design View” option, which is the recommended option.

3. The Show Table window is displayed and allows the user to select one or more tables
(or queries) on which to base a new query. Select EXPERIMENT_SECTION and
click the “Add” button. Close the window.

4. Figure 15 shows the design view of a query based on the EXPERIMENT_SECTION
table. The windows can be enlarged to display table and fieldnames completely. The
“*” represents all fields in the table.

5. Highlight all fields listed under EXPERIMENT_SECTION except the “*” and drag

them onto the grid. Alternately, drag the “*” onto the grid as well as the

STATE_CODE field; unclick the Show check box on the STATE_CODE field, so it

doesn’t display twice.

Type a “1” in the Criteria row in the STATE_CODE column of the grid.

7. Eﬁgv_igw the records selected by the query by clicking on the datasheet view button

o

J,

displayed. Click on the design view button == to return to the design grid.
8. The SQL view of the query is displayed by selecting View > SQL View from the
main menu. Users familiar with SQL can make changes to the query in this window.

Fil= Edit Wisw Insert Query Tools Window Help |

I
Em-[ =i & = e s[5 = |- = == =

158 Query1 : Select Query

[Ready Tt |yl WP |

Figure 15. Query Design View Window
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9. Click the Run button ! I on the toolbar to run the query. This will again display the
datasheet view of the selected records.

10. If the query requires additional changes, return to the design view to change criteria,
fields displayed, or table relationships.

11. Once the results are satisfactory, save the query by clicking on the Save button | 18 |
Give the query a descriptive name and click OK.

Complex Queries

Queries that are based on more than one object (table or query) can be very long and
complex. In the beginning, it is best to allow Access to build the query rather than using
the SQL View to manually enter fieldnames and selection criteria. Successful query
development is dependent on the user’s understanding of table relationships and table
joining.

Table Relationships

MS Access is a relational database package. In other words, rather than storing all
related data in one table, which would be very large and cumbersome, data is divided into
discreet chunks that can be linked together when necessary. For example, in a product
database, suppliers and products should be stored in two different tables. Otherwise, the
supplier information would be repeated for each of its products, wasting a lot of space.
Fields such as SUPPLIER_ID and PRODUCT _ID could be used to link suppliers and
products across tables.

In Access, links (also relationships or joins) between tables can be defined from the
Database screen by clicking the Relationships Button :r‘ll::ll . The Show Table Window

3
will be displayed (see Figure 16), or the Show Table Button Bl can be clicked to select
tables for which relationships will be defined. Once tables are selected, close the Show
Table Window. Click and drag fields from one table list to the matching field in another
table list to begin defining the relationship between the two tables. The Edit
Relationships Window is displayed and the remainder of the relationship should be
defined in this window. See more information in Access about the different types of
relationships (joins) that can be defined.

Table relationships can also be defined in the Query Design View Window. This is easy
to do by clicking and dragging a field from one table list to the matching field in another
table list. Lines will appear between the matching fields to indicate the relationship (see
Figure 17). Join type can be defined by double-clicking on each join line.

Note: Each field in the relationship between two tables must be defined with the
same type of join or the following error message will be displayed when the query is
executed:
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Figure 16. Show Table Window

Joining Tables

Joining tables is done in a query to select and display related data from two or more
tables (or queries). If table relationships are defined correctly, Access will generate the
join statements when the query is generated. In the product database example, mentioned
above, a query to list all suppliers that carry a particular product would require the
Products and Suppliers tables to be joined. Before designing the query to select and
display the product/supplier data, the relationship between the tables must be defined.

Advanced users may use the SQL View in the Query Design Window to write their own
queries. Join statements must be written properly to ensure reasonable and accurate
results.

It is critical that relationships between tables be defined completely.
If tables in a query aren't joined to one another, either directly or
indirectly, Access doesn't know which records are associated with
which, so it displays every combination of records (called a "cross-
product" or "Cartesian product") between the two tables. Therefore,
if each table had 10 records in it, the query's results will contain 100
records (10X10). It also means the query might take a long time to
run and would likely produce less meaningful results.

Cartesian
Product

Joining LTPP Tables

In the LTPP database, joining tables is important for creating subsets of data to be
analyzed. For example, a study of concrete highways overlaid with asphalt might require
the annual number of KESALSs along with other information. The LTPP GPS 7A and 7B
Experiments include asphalt overlaid PCC sections. Experiment information for each
section is found in the EXPERIMENT_SECTION table. Annual KESALSs can be found
in the TRF_MON_EST_ESAL table in the ANL_KESAL_LTPP_LN_YR field.

The EXPERIMENT_SECTION and TRF_MON_EST_ESAL tables can be joined to get

KESALSs for only the GPS7A and GPS7B sections. The Traffic.mdb database file
contains both of these tables, so it can be used as the starting point. Before creating a
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query to get the required data, a relationship between the two tables must be defined
(Figure 17). Listed below are the steps required to define the relationship between these
two tables.

1. Open the Traffic.mdb database file in Access.

2. Click on the Relationships Button £ select the EXPERIMENT_SECTION and
TRF_MON_EST_ESAL tables in the Show Table Window, and click “Add.” Close
the Show Table Window.

| Bile Edit Wiew Belationships Tools window Help |

D SRY|saes|%F S8 <@ 3.

= = Relationships

CM_ASSIGN_DATE RECORD_STATUS
CN_CHANGE_REASON AADT_ALL_VEHIC_ZWaAY
RECORD_STATUS AADT_TRUCK_COMBO_2
AADT_ALL_VEHIC
AADT_TRUCK_COMBO
AML_KESAL_LTPP_LN_¥F
METH_EST_AADT TOT

e [ o T
Figure 17. EXPERIMENT_SECTION and TRF_MON_EST_ESAL with join lines

3. All related fields (key and non-key) should be included in the table relationship.
(Key fields are bolded in the table lists.) Click and drag the STATE_CODE field
from the EXPERIMENT_SECTION table over to the STATE_CODE in the
TRF_MON_EST ESAL table. The Edit Relationships Window will be displayed
with the STATE_CODE portion of the join shown (Figure 18).

Edit Relationships [ el |
Table/Cuery: Related Table/Query:
|exrerimEnT SECT T TRE_Mon_EST Esal x|

Cancel |
STATE_CODE ;I STATE_CODE -
Jain Type. . |
-
g Create Mew, .
1 Enforce Referential Inkegrib————————— ml

I~ Cascade Update Related Fields
I~ Cascade Delete Related Records

Relationship Type: ‘ Indeterminate ‘

Figure 18. Edit relationship for EXPERIMENT_SECTION, TRF_MON_EST_ESAL

4. The SHRP_ID fields in the two tables are related and must be included in the join.
Therefore, click in the second cell in the grid under EXPERIMENT_SECTION, click
the down arrow, and select SHRP_ID from the list.

5. Select SHRP_ID in the second cell under TRF_MON_EST_ESAL.
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6. Click the “Create” button. Notice that the keys CONSTRUCTION_NO and
YEAR_MON_EST have not been included in the join. Both of these fields are date
references, but they cannot be matched up directly.

7. Save and close the Relationships Window.

Create a Multi-Object Query

Once relationships have been defined, a query can be generated through the Query
Design View Window by following the steps below.

1. In the Database Window, click on “Queries” in the “Objects” list.

2. Double-click “Create query in Design view” in the query list. The Query Design
View Window (Figure 15) will be displayed with the Show Table Window (Figure
16) on top.

3. Selectand Add EXPERIMENT_SECTION and TRF_MON_EST_ESAL.

The user must decide at this point which fields from each object to include in the query
results. All fields that are needed for specifying query criteria must be included, along
with any fields that could be useful to analysis. The field list should generally include all
key fields except for duplicates. Fields can be added or removed as necessary. In this
example, the following fields will be included (notice the table.field notation):

EXPERIMENT_SECTION.STATE_CODE
EXPERIMENT_SECTION.SHRP_ID
EXPERIMENT_SECTION.CONSTRUCTION_NO
EXPERIMENT_SECTION.GPS_SPS
EXPERIMENT_SECTION.EXPERIMENT_NO
TRF_MON_EST_ESAL.YEAR_MON_EST
TRF_MON_EST ESAL.ANL_KESAL_LTPP LN_YR

4. Select each field listed above and drag it onto the query design grid (Figure 19).
== =10l

D [t Yew [nest Query fook Windw e
B-RERY|raays@- ] Rz]a @NTa-0-

Fnady = I 3. v

Figure 19. Design View of KESAL Query
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5. Inthe Criteria row on the grid, specify the following values:
GPS_SPS “G”

EXPERIMENT_NO Like “TA” or “7B”

6. Click the Datasheet View Button = for a preview of the selected records. Notice
that there are records that are exact duplicates except for the CONSTRUCTION_NO
field.

7. To see one record for each available KESAL value per year per section, remove
CONSTRUCTION_NO from the query design grid (select column and press Delete)
and set the UniqueValues property to “Yes” in the query’s property sheet. To display
the query’s property sheet, select the query by clicking anywhere in query Design

view outside the design grid and the field lists; click the Properties button on
the toolbar.

If the query's results include more than one field, the combination of
values from all fields must be unique for a given record to be
included in the results.

UniqueValues
Property = Yes

8. Preview the records.

9. Click the Save icon | Bl , give the query a descriptive name, and click OK.
10. Close the query window.

Once the Query is created, it will be added to the Queries Object list. Double-clicking on
the name of the query will run the query and display the results on the screen.

More Information
For more information about the LTPP data or LTPP program, contact John Rush or
Miriam Pitz at the LTPP Customer Support Service Center:

LTPP Customer Support Service Center
Phone: (865)481-2967

Fax: (865)481-8555

Email: Itppinfo@fhwa.dot.gov
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Appendix A

Listed below are the contents of each CD enclosed in this data package. Each zip file expands
to an Access 2000 database with the same name, and the name indicates the type of data in the
database. Each database also contains the administrative tables CODES, CODETYPES,
EXPERIMENT_SECTION, LTPPTD (Table Descriptions), and LTPPDD (Data Dictionary).

Volume 1: Primary Data Set

Administrative.zip Maint_Rehab.zip
Auto_Weather_Station.zip Material_Test.zip
Backcalculation.zip Monitoring.zip

Climate.zip Seasonal_Monitoring.zip
Dynamic_Load_Response.zip Specific_Pavement_Studies.zip
Ground_Penetrating_Radar.zip Traffic.zip

Inventory.zip

Volume 2: FWD Measurement Data
FWD_DATA WITHOUT_DROP_DATA.zip
FWD_DROP_DATA _STATES AL _ID.zip
FWD_DROP_DATA _STATES_IL_MO.zip
FWD_DROP_DATA _STATES MT_TN.zip
FWD_DROP_DATA STATES_TX_SK.zip

Volume 3: Profile Data - 1
Profile_Data_States AL_AZ
Profile_Data_States AR_CA
Profile_Data_States CO_HI
Profile_Data_States ID_IA

Volume 4: Profile Data - 2
Profile_Data_States KS_MI
Profile_Data_States MA _MN
Profile_Data_States MT_NM
Profile_Data_States NY_ OK

VVolume 5: Profile Data - 3
Profile_Data_States OR_TN
Profile_Data_States PR_SK
Profile_Data_States TX
Profile_Data_States UT VA
Profile_Data_States WA_WY
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